Back to overview
Downtime
Dec 5, 2024 at 8:34am UTC
Affected services
Ducky
Resolved
Dec 5, 2024 at 8:34am UTC
The bill had to be paid, thank you rae for paying for our hosting!
Affected services
Resolved
Dec 5, 2024 at 8:34am UTC
The bill had to be paid, thank you rae for paying for our hosting!
Affected services